[Acknowledged] Can't submit review

I just finished Mr. Queen and wanted to leave a review, but when I clicked the Submit button, I got an “Oh no, we weren’t able to submit the review” message. I tried removing punctuation marks (eg dashes) and shortened the review, but continued to get the same error message.
Anyone else having this problem or know what’s causing it?


Yes, I mentioned that before that i wasn’t able to submit a review on a movie so they call them ‘‘bugs’’ I call that annoying to the core. As you can see no one in the ‘‘staff department’’ has given an explanation as to what’s going on with the review section. and help center is a laugh to bother with that…

PS. How was Mr. Queen the ending? Worth watching?

Review posting problem were occurring a month ago, maybe it’s back. I left a note on the other thread for Viki staff.

Yes! Definitely worth watching!

1 Like

Well, when I logged in just now I was able to submit the review without a problem, so I guess it was a momentary glitch.

1 Like

It’s really good, the story is interesting and fun. All the actors/actresses were good but I loved Shin Hye Sun, she was amazing, She deserves an award for this drama.


@luledo @lutra Hmm, that’s strange. We’re currently investigating - we’ll keep everyone updated once we have the latest.

I wasn’t able to submit a review for The Player today, so I guess the problem is still persisting? :pensive:

I guess so since the title of the topic changed to - acknowledged.

1 Like

Someone is out to get me…I tried to post a comment on instagram and it wont post either :roll_eyes::tired_face:

1 Like