I need help with my default browser language on Viki.com

I was on discuss and clicked on a user’s name and it sent me to a webpage where everything was in Spanish. Now when I go to Viki everything is in Spanish and it’s driving me crazy.

I went to chrome and reset my catche and cookies and stuff and when I logged into viki again, it was still coming up in Spanish, not English. I went into settings and I choose my language as English but that didn’t do anything so I reset everything again and it has not changed. Can anyone tell me where to go on my settings or where ever so I can get back on English language please? Thank you.

Finally I found the solution. It’s not the ‘language’ you choose from your ‘settings’. You have to go all the way down to the end of the Viki.com main page and change your language at end of the webpage. Took me forever to figure it out. Here’s the link I found by using google.com to search for it.
I was in help center it was not giving me any options remotely close to what I was looking for.



there are 2 places to set the language, to me it once happened to be Chinese but I remembered the spot, so I was able to fix it :slight_smile:
good for you that you found it and were able to fix it!

Should have looked here in discussions instead of google. There were at least 2 threads about it. But I’m happy you figured it out at last.

1 Like

I looked at two topics and it kept saying send a help request to viki support and then made the topic while I searched for more info. I guess I’m a bit impatient. :wink:

Simi is my sister’s name. Very rare to see that name. xD

1 Like

there is a californian wine called SIMI as well :slight_smile:

1 Like