Turn Off Time Comments Forever

Does someone know of a way to permanently turn off the timed comments? All of a sudden I’m getting the timed comments at the start of EVERY episode I’m watching, regardless of the title or type. I’ve never watched the time comments or added to them so I would like to turn them off permanently. Help! Any useful comments would be greatly appreciated!

This information is at the help center

I am well aware of the way to turn off the timed comments, but this isn’t a permanent fix. In the past, you had to turn on the timed comments if you wanted to see them. Now they show up at the start of every video, whether you want them or not. I would like to see that stop, or a way to permanently stop the timed comments.

“Normally”, if you turn off the timed comments it should be for good. I am no techie, but sometimes I suspect updates or cookie changes or safety programs and so on, to let them re-appear. So, if you are asking about another way to pause them, … Not to my knowledge.

Hm? That’s not the case for me, and I have them turned off as well. So maybe it is also possibly browser related?

For me, it was the opposite. When I started watching Viki, the Timed Comments always were there. Then at some point, after some update or so, they disappeared and I never bothered to get them back.

HELP! I thought my issue was timed comments, but it’s not. It turns out to be that one my video loads and dialog begins I’m getting a box identified as:
LIVE Caption. I don’t know why I’m getting this. Does anyone know the answer to this and how I can turn it off. Thanks!


You probably have “Learn Mode” turned on. Turn it off in the menu you get by clicking at afbeelding in the lower right corner of the video.

Click on the > after “Subtitles” to choose subtitles in your language of preference.



This is not working. Nothiing happens after I click afbeelding on this button. Is there a way for me to find out the version of Viki I’m running? Or should I delete the app and start over? I’m using a laptop computer.

I just found a new icon at the top of my screen. I clicke on it and it showed that I did in fact have learn mode turned on. Thanks so much for pointing me in the right direction. This is NOW gone!


1 Like